Libreoffice 100% CPU usage

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Libreoffice 100% CPU usage

Alessio Ciregia
Just now I've spotted that any Libreoffice program is reported by top command as using 100% of CPU time (and in fact the fans of the laptop are spinning furiously).
I'm on F27 x86_64, and this happens even with with libreoffice 5.4.4.2-1 and 5.4.4.2-2 (updates-testing).
Has anyone else noticed this behavior? Where can I look to debug it?

Ciao,
A.

_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Libreoffice 100% CPU usage

Joachim Backes
On 01/12/18 06:37, Alessio Ciregia wrote:
> Just now I've spotted that any Libreoffice program is reported by top
> command as using 100% of CPU time (and in fact the fans of the laptop
> are spinning furiously).

Seeing this too on my desktop PC with libreoffice-5.4.4.2-2.fc27.x86_64
(soffice.bin):

strace -p <soffice.bin pid> reports:

...

write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
poll([{fd=9, events=POLLIN}, {fd=14, events=POLLIN}, {fd=18,
events=POLLIN}], 3, 2460) = 1 ([{fd=9, revents=POLLIN}])
read(9, "\1\0\0\0\0\0\0\0", 16)         = 8
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
poll([{fd=9, events=POLLIN}, {fd=14, events=POLLIN}, {fd=18,
events=POLLIN}], 3, 2460) = 1 ([{fd=9, revents=POLLIN}])
read(9, "\1\0\0\0\0\0\0\0", 16)         = 8
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
poll([{fd=9, events=POLLIN}, {fd=14, events=POLLIN}, {fd=18,
events=POLLIN}], 3, 2460) = 1 ([{fd=9, revents=POLLIN}])
read(9, "\1\0\0\0\0\0\0\0", 16)         = 8
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
poll([{fd=9, events=POLLIN}, {fd=14, events=POLLIN}, {fd=18,
events=POLLIN}], 3, 2459) = 1 ([{fd=9, revents=POLLIN}])
read(9, "\1\0\0\0\0\0\0\0", 16)         = 8
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
poll([{fd=9, events=POLLIN}, {fd=14, events=POLLIN}, {fd=18,
events=POLLIN}], 3, 2459) = 1 ([{fd=9, revents=POLLIN}])
read(9, "\1\0\0\0\0\0\0\0", 16)         = 8
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
poll([{fd=9, events=POLLIN}, {fd=14, events=POLLIN}, {fd=18,
events=POLLIN}], 3, 2459) = 1 ([{fd=9, revents=POLLIN}])
read(9, "\1\0\0\0\0\0\0\0", 16)         = 8
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
poll([{fd=9, events=POLLIN}, {fd=14, events=POLLIN}, {fd=18,
events=POLLIN}], 3, 2459) = 1 ([{fd=9, revents=POLLIN}])
read(9, "\1\0\0\0\0\0\0\0", 16)         = 8
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8

...


> I'm on F27 x86_64, and this happens even with with libreoffice 5.4.4.2-1
> and 5.4.4.2-2 (updates-testing).
> Has anyone else noticed this behavior? Where can I look to debug it?
>
> Ciao,
> A.
>
>
> _______________________________________________
> users mailing list -- [hidden email]
> To unsubscribe send an email to [hidden email]
>

Ciao

Joachim Backes

--

Fedora release 27 (Twenty Seven)
Kernel-4.14.13-300.fc27.x86_64


Joachim Backes <[hidden email]>
https://www-user.rhrk.uni-kl.de/~backes/
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Libreoffice 100% CPU usage

Alessio Ciregia
On 01/12/2018 09:43 AM, Joachim Backes wrote:
> On 01/12/18 06:37, Alessio Ciregia wrote:
>> Just now I've spotted that any Libreoffice program is reported by top
>> command as using 100% of CPU time (and in fact the fans of the laptop
>> are spinning furiously).
>
> Seeing this too on my desktop PC with libreoffice-5.4.4.2-2.fc27.x86_64
> (soffice.bin):


It is curious: if you open Tools -> Options, the CPU usage drops down.
Until this action, the CPU usage stays around 100%.

Ciao
A.
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Libreoffice 100% CPU usage

Ed Greshko
In reply to this post by Alessio Ciregia
On 01/12/18 13:37, Alessio Ciregia wrote:
> Just now I've spotted that any Libreoffice program is reported by top command as
> using 100% of CPU time (and in fact the fans of the laptop are spinning furiously).
> I'm on F27 x86_64, and this happens even with with libreoffice 5.4.4.2-1 and
> 5.4.4.2-2 (updates-testing).
> Has anyone else noticed this behavior? Where can I look to debug it?
>
>

I have 17 libreoffice 5.4.4.2-1 packages installed on my F27 KDE system.  I have,
almost always, a spreadsheet opened.  I am not seeing any problems.


--
Fedora Users List - The place to go to speculate endlessly


_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]

signature.asc (235 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Libreoffice 100% CPU usage

Alessio Ciregia
On 01/12/2018 10:11 AM, Ed Greshko wrote:
>
> I have 17 libreoffice 5.4.4.2-1 packages installed on my F27 KDE system.  I have,
> almost always, a spreadsheet opened.  I am not seeing any problems.

Just installed Libreoffice on a F27 Cinnamon spin: same problem, 100%
CPU in use by soffice.bin process.

Greetings
A.
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: EXTERNAL: Re: Libreoffice 100% CPU usage

Wells, Roger K.
In reply to this post by Ed Greshko
On 01/12/2018 04:12 AM, Ed Greshko wrote:
On 01/12/18 13:37, Alessio Ciregia wrote:
Just now I've spotted that any Libreoffice program is reported by top command as
using 100% of CPU time (and in fact the fans of the laptop are spinning furiously).
I'm on F27 x86_64, and this happens even with with libreoffice 5.4.4.2-1 and
5.4.4.2-2 (updates-testing).
Has anyone else noticed this behavior? Where can I look to debug it?


I have 17 libreoffice 5.4.4.2-1 packages installed on my F27 KDE system.  I have,
almost always, a spreadsheet opened.  I am not seeing any problems.

pretty much the same here, except using gnome.
Also tried both wayland & xorg.  Same
uname -a:
Linux rwells-x260 4.14.11-300.fc27.x86_64 #1 SMP Wed Jan 3 13:52:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

libreoffice-x11-5.4.4.2-1.fc27.x86_64
HTH

      

_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]


-- 
Roger Wells, P.E.
leidos
221 Third St
Newport, RI 02840
401-847-4210 (voice)
401-849-1585 (fax)
[hidden email]

_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Libreoffice 100% CPU usage

Richard England
In reply to this post by Ed Greshko
On 01/12/2018 01:11 AM, Ed Greshko wrote:

> On 01/12/18 13:37, Alessio Ciregia wrote:
>> Just now I've spotted that any Libreoffice program is reported by top command as
>> using 100% of CPU time (and in fact the fans of the laptop are spinning furiously).
>> I'm on F27 x86_64, and this happens even with with libreoffice 5.4.4.2-1 and
>> 5.4.4.2-2 (updates-testing).
>> Has anyone else noticed this behavior? Where can I look to debug it?
>>
>>
> I have 17 libreoffice 5.4.4.2-1 packages installed on my F27 KDE system.  I have,
> almost always, a spreadsheet opened.  I am not seeing any problems.
>
>
>

No problem here with a spread sheet and writer running at the same
time.  No more than ~15% CPU use

libreoffice-5.4.4.2-1.fc27.x86_64
Linux morse 4.14.11-300.fc27.x86_64 #1 SMP Wed Jan 3 13:52:28 UTC 2018
x86_64 x86_64 x86_64 GNU/Linux
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Libreoffice 100% CPU usage

Heinz Diehl
In reply to this post by Alessio Ciregia
On 12.01.2018, Alessio wrote:

> It is curious: if you open Tools -> Options, the CPU usage drops down.
> Until this action, the CPU usage stays around 100%.

First, FWIW: no problems here with Libreoffice and F27 on three
different machines.

A shot in the dark: what happens when you disable the use of JRE?
The switch is in Tools - Options - Advanced.
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Libreoffice 100% CPU usage

Alessio Ciregia
2018-01-13 8:54 GMT+01:00 Heinz Diehl <[hidden email]>:
>
> A shot in the dark: what happens when you disable the use of JRE?
> The switch is in Tools - Options - Advanced.


This didn't make any difference: still 100% CPU used.

BTW, installing the last update 5.4.4.2-3 (in the update-testing
repo), solved the issue.

Thanks,
Alessio
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Libreoffice 100% CPU usage

Alessio Ciregia
2018-01-20 23:32 GMT+01:00 Alessio Ciregia <[hidden email]>:

> 2018-01-13 8:54 GMT+01:00 Heinz Diehl <[hidden email]>:
>>
>> A shot in the dark: what happens when you disable the use of JRE?
>> The switch is in Tools - Options - Advanced.
>
>
> This didn't make any difference: still 100% CPU used.
>
> BTW, installing the last update 5.4.4.2-3 (in the update-testing
> repo), solved the issue.


Just for info, on bodhi we can read: "The 100% cpu thing is an issue
with a testing update version of glib2 which now has a later version
without that problem, so this libreoffice update is unrelated to
that".


Ciao,
A.
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]