F31 Eclipse-platform won't install, dnf --skip-broken ?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

F31 Eclipse-platform won't install, dnf --skip-broken ?

linux guy

Seems the eclipse-paltform package has a broken dependency, glassfish-el. 

# uname -a
Linux Brix 5.3.15-300.fc31.x86_64 #1 SMP Thu Dec 5 15:04:01 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

dnf install eclipse-platform
Error:
 Problem: conflicting requests
  - package eclipse-platform-1:4.12-6.module_f31+6165+9b01e00c.x86_64 requires glassfish-el >= 3.0.1, but none of the providers can be installed
  - package glassfish-el-3.0.1-0.12.b08.module_f31+6519+12cd0b27.noarch is filtered out by modular filtering
  - package glassfish-el-3.0.1-0.12.b08.module_f31+6793+1c93c38e.noarch is filtered out by modular filtering
  - package glassfish-el-3.0.1-0.11.b08.fc31.noarch is filtered out by modular filtering
(try to add '--skip-broken' to skip uninstallable packages)


# dnf list glassfish-el\*
Installed Packages
glassfish-el-api.noarch               3.0.1-0.7.b08.module_f28+3939+dc18cd75     


# dnf install --skip-broken eclipse-platform
Problem: package eclipse-platform-1:4.12-6.module_f31+6165+9b01e00c.x86_64 requires glassfish-el >= 3.0.1, but none of the providers can be installed
  - cannot install the best candidate for the job
  - package glassfish-el-3.0.1-0.12.b08.module_f31+6519+12cd0b27.noarch is filtered out by modular filtering
  - package glassfish-el-3.0.1-0.12.b08.module_f31+6793+1c93c38e.noarch is filtered out by modular filtering
  - package glassfish-el-3.0.1-0.11.b08.fc31.noarch is filtered out by modular filtering
=======================================================================================================
 Package               Arch        Version                                   Repository           Size
=======================================================================================================
Skipping packages with broken dependencies:
 eclipse-platform      x86_64      1:4.12-6.module_f31+6165+9b01e00c         fedora-modular       39 M

Transaction Summary
=======================================================================================================
Skip  1 Package

Nothing to do.
Complete!


_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/users@...
Reply | Threaded
Open this post in threaded view
|

Re: F31 Eclipse-platform won't install, dnf --skip-broken ?

Ed Greshko
On 2019-12-15 04:04, linux guy wrote:

>
> Seems the eclipse-paltform package has a broken dependency, glassfish-el. 
>
> # uname -a
> Linux Brix 5.3.15-300.fc31.x86_64 #1 SMP Thu Dec 5 15:04:01 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
>
> dnf install eclipse-platform
> Error:
>  Problem: conflicting requests
>   - package eclipse-platform-1:4.12-6.module_f31+6165+9b01e00c.x86_64 requires glassfish-el >= 3.0.1, but none of the providers can be installed
>   - package glassfish-el-3.0.1-0.12.b08.module_f31+6519+12cd0b27.noarch is filtered out by modular filtering
>   - package glassfish-el-3.0.1-0.12.b08.module_f31+6793+1c93c38e.noarch is filtered out by modular filtering
>   - package glassfish-el-3.0.1-0.11.b08.fc31.noarch is filtered out by modular filtering
> (try to add '--skip-broken' to skip uninstallable packages)
>
>

Do....

dnf module enable eclipse:latest
dnf install eclipse-platform


--
The key to getting good answers is to ask good questions.
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/users@...
Reply | Threaded
Open this post in threaded view
|

Re: F31 Eclipse-platform won't install, dnf --skip-broken ?

linux guy
It worked.

# dnf module enable eclipse:latest
Last metadata expiration check: 1:01:55 ago on Sat 14 Dec 2019 03:08:00 PM MST.
Dependencies resolved.
The operation would result in switching of module 'eclipse' stream '2019-06' to stream 'latest'
Error: It is not possible to switch enabled streams of a module.
It is recommended to remove all installed content from the module, and reset the module using 'dnf module reset <module_name>' command. After you reset the module, you can install the other stream.
[root@Brix me]# dnf module reset eclipse
Last metadata expiration check: 1:02:33 ago on Sat 14 Dec 2019 03:08:00 PM MST.
Dependencies resolved.
=======================================================================================================
 Package                 Architecture           Version                  Repository               Size
=======================================================================================================
Resetting modules:
 eclipse                                                                                              

Transaction Summary
=======================================================================================================

Is this ok [y/N]: y
Complete!
[root@Brix me]# dnf module enable eclipse:latest
Last metadata expiration check: 1:02:46 ago on Sat 14 Dec 2019 03:08:00 PM MST.
Dependencies resolved.
=======================================================================================================
 Package                 Architecture           Version                  Repository               Size
=======================================================================================================
Enabling module streams:
 eclipse                                        latest                                                

Transaction Summary
=======================================================================================================

Is this ok [y/N]: y
Complete!
[root@Brix me]# dnf install eclipse-platform
Last metadata expiration check: 1:03:05 ago on Sat 14 Dec 2019 03:08:00 PM MST.
Dependencies resolved.
<packages installed successfully>

On Sat, Dec 14, 2019 at 4:07 PM Ed Greshko <[hidden email]> wrote:
On 2019-12-15 04:04, linux guy wrote:
>
> Seems the eclipse-paltform package has a broken dependency, glassfish-el. 
>
> # uname -a
> Linux Brix 5.3.15-300.fc31.x86_64 #1 SMP Thu Dec 5 15:04:01 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
>
> dnf install eclipse-platform
> Error:
>  Problem: conflicting requests
>   - package eclipse-platform-1:4.12-6.module_f31+6165+9b01e00c.x86_64 requires glassfish-el >= 3.0.1, but none of the providers can be installed
>   - package glassfish-el-3.0.1-0.12.b08.module_f31+6519+12cd0b27.noarch is filtered out by modular filtering
>   - package glassfish-el-3.0.1-0.12.b08.module_f31+6793+1c93c38e.noarch is filtered out by modular filtering
>   - package glassfish-el-3.0.1-0.11.b08.fc31.noarch is filtered out by modular filtering
> (try to add '--skip-broken' to skip uninstallable packages)
>
>

Do....

dnf module enable eclipse:latest
dnf install eclipse-platform


--
The key to getting good answers is to ask good questions.
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/users@...

_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/users@...
Reply | Threaded
Open this post in threaded view
|

Re: F31 Eclipse-platform won't install, dnf --skip-broken ?

John M. Harris Jr
On Saturday, December 14, 2019 4:12:23 PM MST linux guy wrote:

> It worked.
>
> # dnf module enable eclipse:latest
> Last metadata expiration check: 1:01:55 ago on Sat 14 Dec 2019 03:08:00 PM
> MST.
> Dependencies resolved.
> The operation would result in switching of module 'eclipse' stream
> '2019-06' to stream 'latest'
> Error: It is not possible to switch enabled streams of a module.
> It is recommended to remove all installed content from the module, and
> reset the module using 'dnf module reset <module_name>' command. After you
> reset the module, you can install the other stream.
> [root@Brix me]# dnf module reset eclipse
> Last metadata expiration check: 1:02:33 ago on Sat 14 Dec 2019 03:08:00 PM
> MST.
> Dependencies resolved.
> ============================================================================
> =========================== Package                 Architecture          
> Version
>  Repository               Size
> ============================================================================
> =========================== Resetting modules:
>  eclipse
>
>
> Transaction Summary
> ============================================================================
> ===========================
>
> Is this ok [y/N]: y
> Complete!
> [root@Brix me]# dnf module enable eclipse:latest
> Last metadata expiration check: 1:02:46 ago on Sat 14 Dec 2019 03:08:00 PM
> MST.
> Dependencies resolved.
> ============================================================================
> =========================== Package                 Architecture          
> Version
>  Repository               Size
> ============================================================================
> =========================== Enabling module streams:
>  eclipse                                        latest
>
>
> Transaction Summary
> ============================================================================
> ===========================
>
> Is this ok [y/N]: y
> Complete!
> [root@Brix me]# dnf install eclipse-platform
> Last metadata expiration check: 1:03:05 ago on Sat 14 Dec 2019 03:08:00 PM
> MST.
> Dependencies resolved.
> <packages installed successfully>
>
> On Sat, Dec 14, 2019 at 4:07 PM Ed Greshko <[hidden email]> wrote:
> > On 2019-12-15 04:04, linux guy wrote:
> > > Seems the eclipse-paltform package has a broken dependency,
> >
> > glassfish-el.
> >
> > > # uname -a
> > > Linux Brix 5.3.15-300.fc31.x86_64 #1 SMP Thu Dec 5 15:04:01 UTC 2019
> >
> > x86_64 x86_64 x86_64 GNU/Linux
> >
> > > dnf install eclipse-platform
> > >
> > > Error:
> > >  Problem: conflicting requests
> > >  
> > >   - package eclipse-platform-1:4.12-6.module_f31+6165+9b01e00c.x86_64
> >
> > requires glassfish-el >= 3.0.1, but none of the providers can be installed
> >
> > >   - package glassfish-el-3.0.1-0.12.b08.module_f31+6519+12cd0b27.noarch
> >
> > is filtered out by modular filtering
> >
> > >   - package glassfish-el-3.0.1-0.12.b08.module_f31+6793+1c93c38e.noarch
> >
> > is filtered out by modular filtering
> >
> > >   - package glassfish-el-3.0.1-0.11.b08.fc31.noarch is filtered out by
> >
> > modular filtering
> >
> > > (try to add '--skip-broken' to skip uninstallable packages)
> >
> > Do....
> >
> > dnf module enable eclipse:latest
> > dnf install eclipse-platform

Please note that your installation is most likely going to have other package
issues now, as a result of re-enabling the eclipse module, which was recently
disabled because of a package collision with normal packages.

--
John M. Harris, Jr.
Splentity

_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/users@...
Reply | Threaded
Open this post in threaded view
|

Re: F31 Eclipse-platform won't install, dnf --skip-broken ?

Ed Greshko
On 2019-12-15 09:23, John M. Harris Jr wrote:
> Please note that your installation is most likely going to have other package
> issues now, as a result of re-enabling the eclipse module, which was recently
> disabled because of a package collision with normal packages.

I was unaware of that, apparently.  When was that done/announced?


--
The key to getting good answers is to ask good questions.
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/users@...
Reply | Threaded
Open this post in threaded view
|

Re: F31 Eclipse-platform won't install, dnf --skip-broken ?

linux guy
In reply to this post by John M. Harris Jr
It has worked fine thus far.

LG


On Sat, Dec 14, 2019 at 6:33 PM John M. Harris Jr <[hidden email]> wrote:

Please note that your installation is most likely going to have other package
issues now, as a result of re-enabling the eclipse module, which was recently
disabled because of a package collision with normal packages.

_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/users@...